This warning is due to a modification that now requires module authors to specify the Linux license under which the module was released. Beginning with version 5.2.0 WinDriver is registered as a propriety Linux driver. However, you might still receive a similar warning message. (You can take a look at http://lwn.net/2001/1025/a/module-license.php3 for more information). This message is not an indication of any actual error and you can therefore simply ignore it.