Technical Document #50

Technical Document #50
WinDriver Operating Systems Support — Versions Overview

Windows 10 Windows Server 2012 Windows Server 2008 Windows NT 4.0 Mac OS X
Windows 8.1 Windows 7 Windows Server 2003 Windows 98/Me Linux
Windows Server 2012 R2 Windows Server 2008 R2 Windows XP Windows 95 Solaris
Windows 8 Windows Vista Windows 2000 Windows CE VxWorks
NOTE
  • All version information in this document relates to both WinDriver for PCI/ISA and WinDriver for USB, unless otherwise specified.
  • USB 2.0 is supported only beginning with version 5.0.4.
  • PCMCIA is supported only on Windows XP and higher; (until v10.3.1 it was also supported on Windows 2000). Support for PCMCIA was initially added in version 6.2.2.
  • OS-specific support is provided only for operating systems with official vendor support.

Windows 10
Windows 10 x32 and x64 are supported from version 12.0.0.
Windows 10 Technical Preview build 10162 was supported in version 11.9.0.

Windows 8.1
Windows 8.1 x32 and x64 are supported from version 11.4.0.

Windows Server 2012 R2
Windows Server 2012 x32 and x64 are supported from version 11.4.0.

Windows 8
Windows 8 x32 and x64 are supported from version 11.0.0.

Windows Server 2012
Windows Server 2012 x32 and x64 are supported from version 11.0.0.

Windows 7
Windows 7 x32 and x64 are supported from version 10.1.0.
Windows 7 Service Pack 1 is supported from version 10.3.1.

Windows Server 2008 R2
Windows Server 2008 R2 x32 and x64 are supported from version 10.1.0.
Windows Server 2008 R2 Service Pack 1 is supported from version 10.3.1.

Windows Vista
Windows Vista x32 and x64 are supported from version 8.1.0.
Windows Vista Service Pack 1 is supported from version 10.0.0.

Windows Server 2008
Windows Server 2008 x32 and x64 are supported from version 10.0.0.

Windows Server 2003
Windows Server 2003 x64 is supported from version 8.0.0.
Windows Server 2003 x32 is supported from version 6.0.2.

Windows XP
Windows XP x64 is supported from version 8.0.0.
Windows XP Service Pack 3 is supported from version 10.0.0.
Windows XP x32 Service Pack 2 is supported from version 6.2.2.
Windows XP Service Pack 1 is supported from version 5.2.2 to version 8.1.1.
Windows XP Formal Release is supported from version 5.0.4 to version 8.1.1.
Windows XP Release Candidate 1 is supported in version 5.0.3.

Windows 2000 (a.k.a. Win2k)
Windows 2k Service Pack 4 is supported from version 6.0.2 to version 10.3.0.
Windows 2k Service Pack 3 is supported from version 5.0.5b to version 8.1.1.
Windows 2k Service Pack 1 is supported from version 4.3.3 to version 8.1.1.
Windows 2k Formal Release is supported from version 4.3.0 to version 8.1.1.

Windows NT 4.0 (Service Pack 3 or higher)
PCI/ISA — Windows NT 4.0 is supported from the first version (v2.1.0) up to version 8.0.2.
USB — Windows NT 4.0 is supported in version 5.1.x.

Windows 98/Me
PCI/ISA — Windows 98/Me is supported from version 4.0.0 to version 9.2.0.
USB — Windows 98/Me is supported from version 4.3.0 to version 9.2.0.

Windows 95 (PCI/ISA)
Windows 95 is supported (for PCI/ISA) from the first version (v2.1.0) up to version 6.0.1.

Windows CE (a.k.a. Windows Embedded Compact)
Windows Embedded Compact 2013 (a.k.a. WEC2013 or Windows CE 2013) is supported on x86 and ARM platforms from version 11.7.0.
Windows Embedded Compact 7 (a.k.a. WEC7 or Windows CE 7) is supported from version 10.4.0.
Windows Mobile 6.0 is supported from version 9.0.0.
Windows Mobile 5.0 is supported from version 8.0.2.
Windows Embedded CE 6.0 is supported from version 9.0.0.
Windows CE 5.0 is supported from version 6.2.2.
Windows CE 4.x is supported from version 6.0.0.
Windows CE 2.x–3.x is supported for PCI/ISA from version 4.1.2 to 6.0.3.

Mac OS X (PCI)
Mac OS X is supported for PCI from version 10.2.0 to version 10.4.0.

Linux
PCI/ISA — Linux is supported from version 4.1.2.
USB — Linux is supported from version 6.0.0.

Solaris (PCI/ISA)
Solaris is supported for PCI/ISA from version 4.1.4 to version 9.0.1.

VxWorks — a.k.a. DriverBuilder (PCI/ISA)
VxWorks is supported for PCI/ISA from version 4.4.0 to version 5.4.0.